Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Cluster typeSupported VersionsNotes, Limitations and Additional Doc
EMR
  • EMR 5.13 - 5.30.1

EMR 5.28.0 is not supported, due to Spark compatibility issues. Please use 5.28.1 or later.

Avoid EMR 5.30.0. Instead, please use EMR 5.30.1.

Details: Configure for EMR in the Configuration Guide

AWS Databricks
  • AWS Databricks 8.3AWS Databricks 7.3 (Recommended)
  • AWS Databricks 5.5

Details: Configure for AWS Databricks in the Configuration Guide

...

NOTE:
  • Databricks
8.3 is required for user mode access to ADLS Gen2. Azure Databricks
  • 7.3 (Recommended)
  • Azure Databricks 6.x
  • Azure Databricks 5.5 LTS
Cluster typeSupported VersionsNotes, Limitations and Additional Doc
Azure Databricks
  • Azure
Databricks 8.3
Info


Info

NOTE: Some versions of Azure Databricks 6.x have already reached End of Life. Customers should upgrade to a version of Azure Databricks that is supported by the vendor. These EOL versions are likely to be deprecated from supported by the

D s platform
in a subsequent release. For more information on supported versions, see https://docs.databricks.com/release-notes/runtime/releases.html#supported-databricks-runtime-releases-and-support-schedule.

Details: Configure for Azure Databricks in the Configuration Guide

HDI
  • HDI 3.6
Details: Supported Deployment Scenarios for Azure in the Install Guide

...

ItemSupported VersionsNotes, Limitations and Additional Doc
Operating System
  • CentOS: 7.4 - 7.9, 8.1

    Info

    NOTE: MySQL 5.7 Community is not supported on CentOS/RHEL 8.1.


  • RHEL: 7.4 - 7.9, 8.1
  • Ubuntu: 16.04 (Xenial), 18.04 (Bionic Beaver)


Info

NOTE: There are additional requirements for some of these operation system versions. See System Requirements.


JavaJava 1.8
NginX1.20.0
NodeJS14.1516.40

Other requirements:

  • Edge node: Platform must be installed on an edge node of the cluster.
  • Root access: Required for installation
  • SSL access: Access to the platform can be limited to SSL only. See Install SSL Certificate in the Install Guide.
  • Internet access: If the
    D s node
    is not connected to the Internet, you must acquire additional software packages for the installation process. See Install Dependencies without Internet Access in the Install Guide.

...