Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Published by Scroll Versions from space DEV and version r092

...

  • If it is integrated with a Cloudera cluster, it must be installed on a gateway node that is managed by Cloudera Manager.
    • If it is integrated with Cloudera Data Platform, it must be installed on an edge node of the cluster.
  •  If it is integrated with a Hortonworks cluster, it must be installed on an Ambari/Hadoop client that is managed by Hortonworks Ambari.
  •  Customers who originally installed an earlier version on a non-edge node will still be supported. If the software is not installed on an edge node, you may be required to copy over files from the cluster and to synchronize these files after upgrades. The cluster upgrade process is more complicated.
  • This requirement does not apply to the following cluster integrations:
    • AWS EMR
    • Azure Databricks

...

Where possible, you should install the same version of Java on the

D s node
and on the cluster with which you are integrating.

  • Java 8  11 (recommendedruntime only)
  • Java 8

Notes on Java versions:


  • OpenJDK 8 is supported.

    Info

    NOTE: If you are using Azure Databricks as a datasource, please verify that openJDKv1.8.0_302 or earlier is installed on the

    D s node
    . Java 8 is required. There is a known issue with TLS v1.3.


  • There are additional requirements related to Java JDK listed in the Hadoop Components section listed below.
  • If you are integrating your
    D s item
    iteminstance
    with S3, you must install the Oracle JRE 1.8 onto the
    D s node
    . No other version of Java is supported for S3 integration. For more information, see S3 Access in the Configuration Guide.

...

See Supported Deployment Scenarios for Cloudera in the Install Guide.

Hortonworks supported distributions

HDP 3.1

...

the

...

See Supported Deployment Scenarios for Hortonworks  in the Install Guide.

EMR supported distributions

...

...


Spark 2.3Spark 2.4Spark 3.0.1
Java 8Required.Required.Required

...