Skip to main content

Hauptmenüs

Greifen Sie über das Hauptmenü von Alteryx Designer auf verschiedene Fenster und allgemeine Aktionen zu.

Image showing the Alteryx Designer main menus.

Datei-Menü

Diese Optionen sind spezifisch für das Erstellen und Arbeiten mit Workflows.

  • Neuer Workflow (Strg+N) : Erstellt einen neuen Workflow (*.yxmd).

  • Vorlagen : Greifen Sie auf Ihre gespeicherten Workflow-, Makro- und App-Vorlagen zu. Weitere Informationen finden Sie unter Vorlagen .

  • Zuletzt gespeicherte öffnen : Zeigt die zuletzt aufgerufenen und gespeicherten Workflows an.

  • Workflow öffnen : Öffnet einen zuvor erstellten Workflow.

    • Durchsuchen : Öffnet einen Workflow, indem nach dem Speicherort gesucht wird, an dem er gespeichert wurde.

    • Alteryx Analytics Cloud : Öffnet einen Designer Desktop-Workflow, den Sie zuvor in einem Arbeitsbereich der Alteryx Analytics Cloud Platform (AACP) gespeichert haben. Weitere Informationen finden Sie unter Cloud Execution for Desktop .

    • Alteryx Server : Öffnen Sie einen Workflow aus Alteryx Server.

      • Alteryx Server für mein Unternehmen : Öffnet einen Workflow vom Server Ihres Unternehmens (Private Gallery). Wenn Sie eine Verbindung zum Server Ihres Unternehmens hergestellt haben, wird die Verbindung mit dem Verbindungsnamen aufgeführt.

      • Neuen Server hinzufügen : Erstellt eine Verbindung zum Server Ihres Unternehmens.

    • Autom. wiederhergestellte Dateien öffnen : Öffnet eine Liste automatisch gespeicherter Dateien. Geöffnete Dateien werden in regelmäßigen Abständen automatisch gespeichert. Das Intervall zur automatischen Speicherung ist standardmäßig aktiviert und kann unter Benutzereinstellungen geändert werden.

  • Workflow-Gruppe öffnen : Öffnet mehrere Workflows, die in einer Workflow-Gruppe gespeichert wurden. Weitere Informationen finden Sie unter Workflow-Gruppe aus einem Dateiverzeichnis öffnen .

  • Verbindungen verwalten : Wenn der Data Connection Manager (DCM) aktiviert ist, können Sie hier die Datenquellen und die Anmeldedaten für die Authentifizierung bei den Datenquellen festlegen.

  • Speichern (Strg+S) : Speichert den aktiven Workflow.

  • Speichern unter : Speichert den aktiven Workflow am ausgewählten Speicherort.

    • Durchsuchen : Navigiert zu einem Dateispeicherort und speichert den Workflow dort.

    • Alteryx Analytics Cloud : Verknüpft Designer Desktop mit der Alteryx Analytics Cloud Platform (AACP) und speichert Ihren Designer Desktop-Workflow in einem AACP-Arbeitsbereich. Weitere Informationen finden Sie unter Cloud Execution for Desktop .

    • Alteryx Server

      • Vorhandene Verbindungen zum Server Ihres Unternehmens werden hier aufgelistet.

      • Neuen Server hinzufügen : Erstellt eine Verbindung zum Server Ihres Unternehmens und speichert den Workflow dort.

    • Vorlagen : Speichern Sie Ihren Workflow, Ihr Makro oder Ihre App als Vorlage, damit Sie sie als Ausgangspunkt für ein zukünftiges Projekt verwenden können. Weitere Informationen finden Sie unter Vorlagen .

  • Workflow-Gruppe erstellen : Speichert alle offenen Workflows, die zuvor als einzelne Workflows gespeichert wurden, in einer Workflow-Gruppe. Weitere Informationen finden Sie unter Workflow-Gruppen speichern .

  • Drucken : Bietet eine Vorschau darauf, wie der Workflow in gedruckter Form aussehen wird.

  • Druckeinstellungen : Öffnet die Einstellungen zum Drucken eines Workflows.

  • Beenden : Schließt Designer.

Bearbeitungsmenü

Die folgenden Optionen sind allgemeine Bearbeitungsfunktionen.

  • Rückgängig (Strg+Z) : Macht die letzte Aktion automatisch rückgängig Aktionen werden chronologisch erfasst, sodass Sie bis zu 32 Aktionen rückgängig machen können.

  • Wiederherstellen (Strg+Y) : Stellt eine Aktion automatisch wieder her, die Sie gerade rückgängig gemacht haben.

  • Ausschneiden (Strg+X) : Löscht ein Objekt und kopiert es in die Zwischenablage zum sofortigen Einfügen.

  • Kopieren (Strg+C) : Kopiert ein Objekt in die Zwischenablage.

  • Einfügen (Strg+V) : Fügt ein kopiertes Objekt ein.

  • Entfernen (Entf) : Löscht das ausgewählte Objekt.

  • Suchen (Strg+F) : Öffnet die Registerkarte Suchen im Fenster Suchen und Ersetzen . Verwenden Sie das Suchen und Ersetzen -Fenster, um Text in Ihrem Workflow zu suchen, finden und zu ersetzen. Weitere Informationen zu dieser Funktion finden Sie in der Dokumentation zum Thema Suchen und Ersetzen .

  • Ersetzen (Strg+H) : Öffnet die Registerkarte Ersetzen im Fenster Suchen und Ersetzen . Verwenden Sie das Suchen und Ersetzen -Fenster, um Text in Ihrem Workflow zu suchen, finden und zu ersetzen. Weitere Informationen zu dieser Funktion finden Sie in der Dokumentation zum Thema Suchen und Ersetzen .

Ansicht-Menü

Öffnen oder schließen Sie diese Fenster über das Ansicht -Menü:

  • Tool-Palette (Strg+Alt + T) : Zeigt die Tool-Palette unterhalb des Menüs an. Weitere Informationen zur Benutzeroberfläche von Designer finden Sie unter Benutzeroberfläche .

  • Übersicht (Strg+Alt+V) : Zeigt das Übersichtsfenster in seiner zuletzt geöffneten Position an.

  • Ergebnisse (Strg+Alt+R) : Zeigt das Ergebnisfenster in seiner zuletzt geöffneten Position an.

  • Konfiguration (Strg+Alt+C) : Zeigt das Konfigurationsfenster  angedockt in seiner letzten sichtbaren Position an.

  • Schnittstellen-Designer (Strg+Alt+D) : Zeigt das Fenster des Schnittstellen-Designers in seiner zuletzt geöffneten Position an. Weitere Informationen finden Sie unter Schnittstellen-Designer und Schnittstellen-Designer-Fenster .

Optionen-Menü

Diese Optionen ermöglichen den Zugriff auf Workflow-, Planungs- und Lizenzfunktionen auf Benutzereinstellungen.

  • Workflow ausführen : Führt den Workflow aus. Der Workflow kann auch mit der Tastenkombination Strg+R ausgeführt werden. Das Symbol ändert sich in „Workflow anhalten“, während der Workflow ausgeführt wird.

  • Workflow planen : Plant die Ausführung von Workflows zu spezifischen Zeiten und mit spezifischer Häufigkeit. Der Planungsdienst muss als Teil der Alteryx-Installation aktiviert sein und der Benutzer muss über eine entsprechende Lizenz verfügen. Die Lizenz sollte von einem Administrator installiert werden, um sicherzustellen, dass alle Benutzer ordnungsgemäß lizenziert sind und der Dienst richtig konfiguriert ist. Weitere Informationen finden Sie unter Workflows planen .

  • Zeitpläne anzeigen : Ermöglicht es, Workflows und Anwendungen zu planen, die Aufträge in der Warteschlange zu sehen und Informationen zu abgeschlossenen Aufträgen anzuzeigen. Der Planungsdienst muss als Teil der Alteryx-Installation aktiviert sein und der Benutzer muss über eine entsprechende Lizenz verfügen. Die Lizenz sollte von einem Administrator installiert werden, um sicherzustellen, dass alle Benutzer ordnungsgemäß lizenziert sind und der Dienst richtig konfiguriert ist. Weitere Informationen finden Sie unter Zeitpläne verwalten .

  • Analyse-Apps ausführen : Öffnet das Fenster Analyse-App auswählen , in dem Apps durchsucht, ausgeführt oder bearbeitet werden können. Weitere Informationen finden Sie unter Analyse-App auswählen .

  • Workflow exportieren : Öffnet das Fenster Workflow exportieren , in dem der aktive Workflow mit allen zugehörigen Abhängigkeiten in eine YXZP-Datei komprimiert werden kann. Weitere Informationen finden Sie unter Workflows verwalten .

  • Lizenzen verwalten : Ermöglicht es Ihnen, sich Ihre Alteryx-Lizenzen über den Lizenzmanager anzeigen zu lassen, neue hinzuzufügen oder sie zu löschen.

  • Promote-Verbindung hinzufügen : Öffnet das Fenster „Promote-Verbindungen“, in dem neue Verbindungen zur Promote-Plattform hinzugefügt werden können. Um alle Verbindungen anzuzeigen oder eine Verbindung zu löschen, öffnen Sie das Bereitstellen-Tool oder das Bewertung-Tool . Deploy Tool

  • Connect-Anmeldedaten verwalten : Öffnet das Fenster Connect-Anmeldung , über das Sie auf Connect zugreifen können. Weitere Informationen finden Sie unter Connect Assets verwenden .

  • Benutzereinstellungen : Konfiguriert das Design eines Workflows und legt die Nutzung von Systemressourcen fest, um die Leistung des Projekts benutzerspezifisch zu optimieren. Weitere Informationen finden Sie unter Benutzereinstellungen .

    • Benutzereinstellungen bearbeiten : Weitere Informationen finden Sie unter Benutzereinstellungen .

    • Layout und Einstellungen beim Beenden speichern : Speichert das GUI-Layout und die benutzerspezifischen Einstellungen, wenn das Programm beendet wird.

    • Layout und Einstellungen jetzt speichern : Speichert das GUI-Layout und die benutzerspezifischen Einstellungen.

    • Standardwerte wiederherstellen : Stellt die ursprünglichen Ausrichtung des GUI-Layouts wieder her.

  • Erweiterte Optionen

    • Workflows vergleichen : Vergleicht zwei Workflows und zeigt die Unterschiede anhand visueller Indikatoren schnell an. Weitere Informationen und Anleitungen finden Sie unter Workflows vergleichen .

    • Workflow sperren : Speichert eine Kopie eines Workflows, damit dieser zwar ausgeführt, aber nicht in Alteryx Designer geöffnet und bearbeitet werden kann. Weitere Informationen und Anleitungen finden Sie unter Workflow sperren .

    • Datenverbindungen verwalten : Erstellen und verwalten Sie Ihre Datenverbindungen an einem zentralen Ort. Sie können die von Ihnen erstellten Verbindungen, die für Sie freigegebenen Verbindungen anzeigen und neue Verbindungen hinzufügen. Weitere Informationen finden Sie unter Datenverbindungen verwalten .

    • In-DB Verbindungen verwalten : Erstellen und verwalten Sie Ihre In-Database-Verbindungen an einem zentralen Ort. Schauen Sie sich bestehende In-Database-Verbindungen an und fügen Sie neue In-Database-Verbindungen hinzu. Weitere Informationen finden Sie unter In-DB-Verbindungen verwalten .

    • HTML-Entwickler-Tools anzeigen : Öffnet automatisch das Fenster Alteryx-HTML-Entwickler-Tools , wenn Sie ein Tool oder Fenster auswählen, das das Chromium Embedded Framework verwendet.

    • Systemeinstellungen : Geben Sie die Nutzung der Systemressourcen an, um die Leistung der Anwendung zu optimieren. Zur Änderung der Systemeinstellungen sind Administratorrechte erforderlich. Weitere Informationen finden Sie unter Systemeinstellungen .

    • Workflow-Abhängigkeiten : Steuert die Ein- und Ausgabepfade, die mit dem Workflow verknüpft sind, sowie die spezifischen Datasets. Weitere Informationen finden Sie unter Workflow-Abhängigkeiten .

  • Prognose-Tools herunterladen : Die Prognose-Tools verwenden die Programmiersprache R. Navigieren Sie zu Optionen  > Prognose-Tools herunterladen und melden Sie sich beim Alteryx Downloads and Licenses-Portal an, um R und die vom R-Tool verwendeten Pakete zu installieren.

Hilfe-Menü

Diese Optionen bieten schnellen Zugriff auf Hilfe für Alteryx Designer.

  • Alteryx-Hilfe : Öffnet die Designer-Hilfe. Sie können auch über die F1-Taste auf Hilfe zugreifen.

  • Tutorials : Öffnet Tutorial-Workflows, die eine Einführung in die Erstellung von Workflows in Designer bieten.

  • Beispiel-Workflows : Öffnet die in Designer verfügbaren Beispiel-Workflows, einschließlich externer Installationen wie Starter-Kits. Weitere Informationen finden Sie unter Beispiel-Workflows .

  • Beispiel-Datasets : Öffnet die Beispiel-Datasets, die in Designer verfügbar sind.

  • Community : Link zur Alteryx-Community-Site, wo Sie Zugang zu unseren Benutzerforen, Support-Fragen, Workflow-Austausch, häufig gestellten Fragen und mehr finden.

  • Neuerungen : Öffnet die Hilfeseite der Neuerungen zur aktuellen Designer-Version. Diese Seite führt die neuen Funktionen und Verbesserungen seit der letzten offiziellen Version auf.

  • Auf Aktualisierungen prüfen : Designer prüft, ob eine neuere Version als die jetzige verfügbar ist. Diese Funktion erfordert eine Internetverbindung. Weitere Informationen finden Sie unter Versionsaktualisierungen .

  • Supportdatei generieren : Erstellt eine technische Support-Datei, die alle notwendigen Informationen enthält, damit unser Team den Fehler sachgerecht beheben kann. Die Datei enthält die Laufzeiteinstellungen und Ihre Seriennummer (E-Mail-Adresse). Sie können diese Datei hochladen, wenn Sie Ihren Support-Fall einsenden. Prüfen Sie den Dateiinhalt, und entfernen Sie alles, was Sie nicht senden möchten.

  • Alteryx-Downloads : Öffnet das Portal Alteryx Downloads and Licenses , in dem Sie die aktuelle Software-Version herunterladen können.

  • Info : Öffnet ein Dialogfeld mit den Designer-Versionsinformationen und der eindeutigen Seriennummer für die Lizenz.

  • Datenschutzrichtlinien : Zugriff auf die Datenschutzrichtlinien .

  • Endbenutzer-Lizenzvereinbarung : Zugriff auf die Endbenutzer-Lizenzvereinbarung .

Lokalisierungsmenü (Globus-Symbol)

Wählen Sie die Sprachversion für Designer aus. Zu Ihren Optionen gehören:

  • Englisch

  • 简体中文  (Vereinfachtes Chinesisch)

  • Français (Französisch)

  • Deutsch (German)

  • Italiano (Italienisch)

  • 日本語 (Japanisch)

  • Português (Portugiesisch)

  • Español (Spanisch)

Über das Lokalisierungsmenü können Sie auch schnell auf die Lokalisierungseinstellungen zugreifen.

Symbolleiste

Über die Symbolleiste oberhalb des Hauptmenüs haben Sie Zugriff auf diese Aktionen:

Image showing the Designer toolbar.
  • Workflow öffnen (Strg + O) : Navigieren Sie zu einem Dateispeicherort, um einen zuvor erstellten Workflow zu öffnen.

  • Speichern (Strg+S) : Speichert den aktiven Workflow.

  • Ausschneiden (Strg+X) : Löscht ein Objekt und kopiert es in die Zwischenablage zum sofortigen Einfügen.

  • Kopieren (Strg+C) : Kopiert ein Objekt in die Zwischenablage.

  • Einfügen (Strg+V) : Fügt ein kopiertes Objekt ein.

  • Rückgängig machen (Strg+Z) : Macht die letzte Aktion rückgängig. Aktionen werden chronologisch erfasst, sodass Sie bis zu 32 Aktionen rückgängig machen können.

  • Wiederherstellen (Strg+Y) : Stellt eine Aktion wieder her, die Sie gerade rückgängig gemacht haben.