Skip to main content

主菜单

从 Alteryx Designer 的主菜单访问各个窗口和常见操作。

Image showing the Alteryx Designer main menus.

文件菜单

这些选项专门用于创建和使用工作流。

  • 新建工作流 (Ctrl+N) :创建新工作流 (*.yxmd)。

  • 模板 :访问已保存的工作流、宏和应用程序模板。如需了解详细信息,请前往 模板

  • 最近打开项 :显示最近访问和保存的工作流。

  • 打开工作流 :打开之前创建的工作流。

    • 浏览 :通过浏览至保存某个工作流的文件位置来打开该工作流。

    • Alteryx Analytics Cloud :打开您之前保存到 Alteryx Analytics Cloud Platform (AACP) 工作区的 Designer Desktop 工作流。如需了解详情,请参阅 Cloud Execution for Desktop

    • Alteryx Server:从 Alteryx Server打开工作流。

      • 我公司的 Server :从您公司的 Server(私有 Gallery)打开工作流。如果您已连接到公司的 Server,则连接将按连接名称列出。

      • 添加新 Server :创建与公司 Server 的连接。

    • 打开自动恢复的文件 :打开自动保存的文件列表。打开的文件会定期自动保存。自动保存时间间隔默认已启用,但可在 用户设置 中进行修改。

  • 打开工作流组 :打开已保存到工作流组中的多个工作流。有关详细信息,请转至 从文件目录打开工作流组

  • 管理连接 :启用 数据连接管理器 (DCM) 后,请转至此处以控制数据源和凭证,以便对数据源进行身份验证。

  • 保存 (Ctrl+S) :保存处于活动状态的工作流。

  • 另存为 :将处于活动状态的工作流保存到选定位置。

    • 浏览 :浏览至某个文件位置并将工作流保存在该位置。

    • Alteryx Analytics Cloud :将 Designer Desktop 与 Alteryx Analytics Cloud Platform (AACP) 进行链接,并将 Designer Desktop 工作流保存到 AACP 工作区。如需了解详情,请参阅 Cloud Execution for Desktop

    • Alteryx Server

      • 此处列出了与您公司的 Server 的现有连接。

      • 添加新 Server :创建与您公司的 Server 的连接,并将工作流保存在该位置。

    • 模板 :将您的工作流、宏或应用程序保存为模板,以便您可以将其用作未来项目的起点。如需了解详细信息,请前往 模板

  • 创建工作流组 :将所有打开的工作流(之前另存为单个工作流)另存为工作流组。有关更多详细信息,请转至 保存工作流组

  • 打印 :提供工作流的打印预览。

  • 打印设置 :打开用于打印工作流的设置。

  • 退出 :关闭 Designer。

编辑菜单

这些选项是常用的编辑功能。

  • 撤消 (Ctrl+Z) :自动撤消上一个操作。操作会有历史纪录,因此您最多可以撤消 32 个操作。

  • 恢复 (Ctrl+Y) :恢复您刚才撤消的操作。

  • 剪切 (Ctrl+X) :删除对象并将其复制到剪贴板,以便立即粘贴。

  • 复制 (Ctrl+C) :将对象复制到剪贴板。

  • 粘贴 (Ctrl+V) :粘贴已复制的对象。

  • 删除 (Del) :删除选定的对象。

  • 查找 (Ctrl+F) :打开 查找和替换 窗口的 查找 选项卡。使用 查找和替换 窗口在工作流中搜索、查找和替换文本。请转至 查找和替换 文档以了解有关此功能的更多信息。

  • 替换 (Ctrl+H) :打开 查找和替换 窗口的 替换 选项卡。使用 查找和替换 窗口在工作流中搜索、查找和替换文本。请转至 查找和替换 文档以了解有关此功能的更多信息。

视图菜单

通过 视图 菜单打开或关闭这些窗口:

  • 工具面板 (Ctrl+Alt+T): 在菜单下显示工具面板。有关 Designer 用户界面的详细信息,请转至 用户界面

  • 概览 (Ctrl+Alt+V) :显示停靠在最后一个可见位置的 概览窗口

  • 结果 (Ctrl+Alt+R) :显示停靠在最后一个可见位置的 结果窗口

  • 配置 (Ctrl+Alt+C) :显示停靠在最后一个可见位置的 配置窗口

  • 界面设计器 (Ctrl+Alt+D) :显示停靠在最后一个可见位置的界面设计器窗口。有关详细信息,请转至 界面设计器 界面设计器窗口

选项菜单

通过这些选项可以访问工作流、计划、许可证功能以及用户设置。

  • 运行工作流 :运行工作流。Ctrl+R 键盘快捷键也可运行工作流。工作流运行时,该图标更改为停止工作流。

  • 计划工作流 :计划在特定时间和以特定频率运行工作流。Scheduler Service 必须作为 Alteryx 安装的一部分启用,并且用户必须获得相应的许可。许可证应由管理员安装,以确保所有用户都获得正确的许可,并且服务得到正确配置。有关详细信息,请访问 计划工作流

  • 查看计划 :计划工作流和应用程序,查看队列中的作业,以及查看有关已完成作业的信息。Scheduler Service 必须作为 Alteryx 安装的一部分启用,并且用户必须获得相应的许可。许可证应由管理员安装,以确保所有用户都获得正确的许可,并且服务得到正确配置。有关详细信息,请转至 管理计划

  • 运行分析应用程序 :打开 选择分析应用程序 窗口,您可以通过该窗口浏览应用程序并编辑或运行这些应用程序。有关更多详细信息,请转至 选择分析应用程序

  • 导出工作流 :打开 导出工作流 窗口,该窗口允许您获取活动工作流并将其与所有依赖项压缩到 *.yxzp 文件。有关更多详细信息,请转至 工作流管理

  • 管理许可证 :通过许可证管理器查看、添加和删除您的 Alteryx 许可证。

  • 添加 Promote 连接 :打开“Promote 连接”窗口,您可以通过该窗口将连接添加到 Promote 平台。要查看所有连接或删除某个连接,请访问 “部署”工具 “评分”工具  Deploy Tool

  • 管理 Connect 凭据 :打开 Connect 登录 窗口,您可以通过该窗口访问 Connect。有关更多详细信息,请转至 使用 Connect 资产

  • 用户设置 :配置工作流外观和指定系统资源使用情况,以优化特定于用户的项目性能。有关详细信息,请访问 用户设置

    • 编辑用户设置 :有关更多详细信息,请转至 用户设置

    • 退出时保存布局和设置 :退出程序时保存 GUI 布局和用户指定的设置。

    • 立即保存布局与配置 :保存 GUI 布局和用户指定的设置。

    • 恢复默认值 :将 GUI 布局恢复为其初始方向。

  • 高级选项

    • 对比工作流 :对比 2 个工作流,并通过可视指示器快速识别差异。有关说明和其他信息,请转至 对比工作流

    • 锁定工作流 :保存工作流的副本,以便可以运行但不能在 Alteryx Designer 中打开和编辑该工作流。有关说明和其他信息,请转至 锁定工作流

    • 管理数据连接 :从中央位置创建和管理数据连接。查看您创建的连接和与您共享的连接,以及添加新连接。有关详细信息,请转至 管理数据连接

    • 管理库内连接 :从中央位置创建和管理库内连接。查看现有的库内连接并添加新的库内连接。有关更多详细信息,请转至 管理库内连接

    • 显示 HTML 开发工具 :当您选择使用 Chromium 嵌入式框架 的工具或窗口时,将自动打开 Alteryx HTML 开发工具 窗口。

    • 系统设置 :指定系统资源使用情况以优化应用程序的性能。系统设置需要管理员权限才能更改。有关详细信息,请转至 系统设置

    • 工作流依赖项 :控制与工作流以及特定数据集关联的输入和输出路径。有关详细信息,请转至 工作流依赖关系

  • 下载预测工具 :预测工具使用 R 编程语言。转到 选项  > 下载预测工具 ,并登录到 Alteryx 下载和许可证 门户以安装 R 和 R 工具 使用的软件包。

帮助菜单

通过这些选项,您可快速访问 Alteryx Designer 的帮助。

  • Alteryx 帮助 :打开 Designer 帮助。您也可以通过 F1 键盘快捷键访问帮助。

  • 教程 :打开教程工作流,其中会介绍如何在 Designer 中构建工作流。

  • 示例工作流 :打开 Designer 中提供的示例工作流,包括初学者工具包等外部装置。有关详细信息,请转至 示例工作流

  • 示例数据集 :打开 Designer 中提供的示例数据集。

  • 社区 :指向 Alteryx 社区站点的链接,您可以在该站点访问我们的用户论坛、支持问题、工作流交换、常见问题等。

  • 新增功能 :打开 Designer 当前发行版本的 新增功能帮助页面 。此页面重点介绍自上一次正式发行以来的新功能和增强功能。

  • 检查更新 :Designer 检查是否有比当前版本更新的版本可用。此功能需要 internet 连接。有关详细信息,请转至 版本更新

  • 生成支持文件 :生成技术支持文件,其中包含有助于我们的团队对您的问题正确进行故障排除的信息。该文件包括运行时设置和序列号(电子邮件地址)。您可以在提交支持案例时上传此文件。请务必检查文件内容并删除任何您可能不想包含的内容。

  • Alteryx 下载 :打开 Alteryx 下载和许可 门户,您可以在其中下载最新版本的软件。

  • 关于 :打开一个对话框,其中包含 Designer 版本信息和许可证的唯一序列号。

  • 隐私政策 :访问 隐私政策

  • 最终用户许可协议 :访问 最终用户许可协议

本地化菜单(地球图标)

选择 Designer 的语言版本。您的选择包括...

  • 英语

  • 简体中文 (简体中文)

  • Français (法语)

  • Deutsch (德语)

  • Italiano (意大利语)

  • 日本語 (日语)

  • Português (葡萄牙语)

  • Español (西班牙语)

通过本地化菜单还可以快速访问 本地化用户设置

工具栏

通过主菜单上方的工具栏可以访问这些操作:

Image showing the Designer toolbar.
  • 打开工作流 (Ctrl+O) :浏览至文件位置以打开之前创建的工作流。

  • 保存 (Ctrl+S) :保存处于活动状态的工作流。

  • 剪切 (Ctrl+X) :删除对象并将其复制到剪贴板,以便立即粘贴。

  • 复制 (Ctrl+C) :将对象复制到剪贴板。

  • 粘贴 (Ctrl+V) :粘贴已复制的对象。

  • 撤消 (Ctrl+Z) :自动删除上一个操作。操作会有历史纪录,因此您最多可以撤消 32 个操作。

  • 恢复 (Ctrl+Y) :重复您刚才所撤消的操作。